Ask Your Question
0

SuperDirt installation (Quark not found in repository)

asked 2016-07-15 09:58:03 -0500

nostromo gravatar image

updated 2016-07-25 06:58:39 -0500

lennart gravatar image

I'm having trouble completing my installation. Everything seems to have gone fine until I try to get SuperDirt to be activated in SC. After shift-entering include("SuperDirt") in the SC IDE, I'm receiving the following error.

init_OSC
empty
compiling class library...
NumPrimitives = 677
compiling dir: '/usr/share/SuperCollider/SCClassLibrary'
compiling dir: '/usr/share/SuperCollider/Extensions'
pass 1 done
numentries = 781754 / 10842358 = 0.072
4969 method selectors, 2182 classes
method table size 5859464 bytes, big table size 43369432
Number of Symbols 11465
Byte Code Size 358237
compiled 319 files in 3.09 seconds
compile done
Couldn't set realtime scheduling priority 1: Operation not permitted
Help tree read from cache in 0.058115005493164 seconds
LID: event loop started
Class tree inited in 0.32 seconds
Welcome to SuperCollider 3.6.3. For help press Ctrl-D.
Couldn't set realtime scheduling priority 1: Operation not permitted
SCDoc: Indexing help-files...
SCDoc: Indexing old helpfiles...
Help files scanned in 0.19773101806641 seconds
SCDoc: Indexed 1308 documents in 6.54 seconds
SuperDirt  not found in local quarks; checking out from remote ...
ERROR: Quark not found in repository.
CALL STACK:
Exception:reportError   0xbc5e850
arg this = <instance of Error>
Nil:handleError   0xbc5ee50
arg this = nil
arg error = <instance of Error>
Thread:handleError   0xbc5ebb0
arg this = <instance of Thread>
arg error = <instance of Error>
Object:throw   0xbc5ec10
arg this = <instance of Error>
Quarks:checkout   0xbc2c8b0
arg this = <instance of Quarks>
arg name = "SuperDirt"
arg version = nil
arg sync = true
var q = nil
Quarks:install   0xbc2cdb0
arg this = <instance of Quarks>
arg name = "SuperDirt"
arg includeDependencies = true
arg checkoutIfNeeded = true
var q = nil
var deps = nil
var installed = nil
var dirname = nil
var quarksForDep = nil
Meta_Quarks:install   0xbc2ce50
arg this = <instance of Meta_Quarks>
arg name = "SuperDirt"
arg includeDependencies = true
arg checkoutIfNeeded = true
String:include   0xbc619d0
arg this = "SuperDirt"
Interpreter:interpretPrintCmdLine   0xbc2d490
arg this = <instance of Interpreter>
var res = nil
var func = <instance of Function>
var code = "include("SuperDirt")"
var doc = nil
var ideClass = <instance of Meta_ScIDE>
Process:interpretPrintCmdLine   0xbc61c70
arg this = <instance of Main>
^^ The preceding error dump is for ERROR: Quark not found in repository.

I can't really figure out whether it's Quarks missing or if it can't find SuperDirt. Git is installed properly.

Any idea of what it could be ? Thanks !


Hi all,

I'm getting an error when trying to include SuperDirt in super collider. I've tried manually updating the repository with svn checkout https://svn.code.sf.net/p/quarks/code/ quarks in both ~/.local/share/SuperCollider/quarks and ~/.local/share/SuperCollider/Extensions/quarks, to no avail.

The getting started guide did mention about the need to download git, but I already have git and the error is different. Does anyone know what am I doing wrong?

SuperDirt  not found in local quarks; checking out from remote ...
ERROR: Quark not found in repository.
CALL STACK:
    Exception:reportError   0x1a02e48
        arg this = <instance of Error>
    Nil:handleError   0x34b8518
        arg this = nil
        arg error = <instance of Error>
    Thread:handleError   0x33b92b8
        arg this ...
(more)
edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
2

answered 2016-07-15 10:51:18 -0500

lennart gravatar image

updated 2016-07-15 10:51:48 -0500

From what I read in the SuperCollider messages you are running version 3.6.3 of SuperCollider which handles Quarks differently. SuperCollider 3.7 is recommended for SuperDirt.

To get SuperDirt working you can either:

  • update SuperCollider to version 3.7 and rerun include('SuperDirt), you can get the latest SuperCollider version from the official website
  • follow the instructions for 3.6 as shown in the last paragraph of the SuperDirt README
edit flag offensive delete link more

Comments

I can't seem to get version 3.7.2 from apt-get on Ubuntu though. Do I need to build it from source?

euwbah gravatar imageeuwbah ( 2016-07-25 21:14:07 -0500 )edit
0

answered 2016-07-25 05:56:28 -0500

andreacane gravatar image

updated 2016-07-25 05:58:10 -0500

I got the same problem using the 3.6 version of supercollider. I upgraded to the 3.7.2 version and found no issues in it. Check which one you are using!

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-07-15 09:58:03 -0500

Seen: 637 times

Last updated: Jul 25 '16