Ask Your Question
0

not getting sound with tidalcycles

asked 2016-07-17 07:43:43 -0500

Ray gravatar image

updated 2016-09-06 17:55:34 -0500

lennart gravatar image

trying to get tidalcycles working. have installed haskell, supercollider and atom on my mac with version 10.11.5 and am not getting any sound. what should i start checking? thanks, ray

edit retag flag offensive close merge delete

3 answers

Sort by ยป oldest newest most voted
0

answered 2016-07-17 17:19:03 -0500

yaxu gravatar image

Hi Ray,

There is SuperDirt that makes sound, and TidalCycles which controls it. So a good starting point is probably testing SuperDirt inside supercollider.

When you run this code (with shift-enter while your cursor is on that line) ...

SuperDirt.start

... you should see in the "post window" (where the output goes, on the right hand side) something about loading some sample banks, and eventually "SuperDirt: listening to Tidal on port 57120". If you get any funny error messages or warnings, then please share them!

Otherwise, you can test SuperDirt makes sound within SuperCollider by running each of these lines in turn (again, with shift-enter):

~d1 = ~dirt.orbits[0];
~d1.((sound: 'cp', speed: 1));

Hopefully you hear a clap sound.

If so, time to check the TidalCycles side. In atom, make sure you have the 'tidalcycles' package installed, and not the old 'tidal' one.

Then run this code:

d1 $ sound "cp"

TidalCycles should boot, and you should again here than clap sound. Again if you don't hear anything and get an error message please share - unfortunately you can't currently copy-and-paste from the error window in atom, but you could take a screenshot instead..

Let us know how you get on..

edit flag offensive delete link more

Comments

hi yaxu supercollider works but i can't find where the error messages are in atom.

Ray gravatar imageRay ( 2016-07-20 08:34:43 -0500 )edit
0

answered 2016-07-18 15:12:09 -0500

Ray gravatar image

@yaxu, thanks will try it out r

edit flag offensive delete link more

Comments

Sorted via the slack channel - for the record, there were two problems, that the 'tidal' atom package was installed as well as the correct 'tidalcycles' one, and that tidal wasn't installed - needed "cabal install tidal" running from the commandline.

yaxu gravatar imageyaxu ( 2016-07-21 05:17:10 -0500 )edit
0

answered 2016-08-14 02:12:00 -0500

Hi,
I'm trying to get Tidalcycles working on xubuntu 16.
So far the superdirt test in SC is passed.
I have an error in Atom about ghci (currently installed: ghc-7.10.3, and there's something happening when i bash ghci):

'ghci' could not be spawned. Is it installed and on your path? If so please open an issue on the package spawning the process.

Did I do anything wrong, should I edit the config, am I missing a package? Any help would be more than welcome.
Thank you, have a nice weekend

edit flag offensive delete link more

Comments

solved via Slack
I had to change the ghci location in the Atom plugin.
bash "which ghci" , for me it was "/opt/ghc/7.10.3/bin/ghci". Copy and paste it in Atom.

pierstu gravatar imagepierstu ( 2016-08-14 16:50:12 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2016-07-17 07:43:43 -0500

Seen: 177 times

Last updated: Sep 06 '16