cabal install tidal problems - Windows

asked 2016-07-19 11:10:10 -0600

this post is marked as community wiki

This post is a wiki. Anyone with karma >1 is welcome to improve it.

So, i'm making this wiki post to clarify some issues i found while installing tidal on my machine, running windows10 64bit.

As of today, on the tidalcycles page for the installation procedure (http://tidalcycles.org/getting_starte...) there is some missing infos for the windows users: to run cabal install tidal you actually need to install a tool named Cygwin.

So here we go: download it from https://cygwin.com/install.html and run the exec. during the setup, you're going to be asked which components of cygwin you desire. make sure you find and add these:

  • gcc-core
  • make
  • gcc-g++

I strongly suggest you to watch this portion of this video https://youtu.be/KPCRUuYsb5M?t=173. This would make you more confident about what you're doing, if you've never put your hands on these things.

Once you've finished the installation, you have to be sure you added the cygwin binaries to you Path Enviroment Variables. So what you need to do is: Find the folder of your cygwin binaries. In my case, it was C:\cygwin64\bin. Copy the path and now go in Control Panel > System and security > System > Advanced System Settings (should be on the right) > Advanced (tab) > Enviroment Variables and check the VALUE of the VARIABLE named Path. Click on Edit and this should open:

what you should kinda see now

If you don't find the C:\cygwin64\bin (or your different binaries folder) line, click on New and add it. Now confirm and open again your cmd.

Now Cygwin should be visible for your system and you should NOT get this error:

setup.exe: The package has a './configure' script. This requires a
Unix compatibility toolchain such as MinGW+MSYS or Cygwin.

while you try to run cabal install cabal-install or cabal install tidal.

Now, if you're as negligent as me, you can experience another issue while running the command:

configure: WARNING: unrecognized options: --with-compiler
checking for gcc... C:\PROGRA~1\HASKEL~1\802E01~1.1\mingw\bin\gcc.exe
checking whether the C compiler works... no
configure: error: in `/tmp/cabal-tmp-8957/old-time-1.1.0.3':
configure: error: C compiler cannot create executables

This is due to a non-complete Haskell installation on your system. To fix this, see this: https://www.haskell.org/platform/

So follow the steps: download and run the setup, the find the config.file: run the cabal user-config init command and find the path of the file, so you can edit it. You have no file yet, just run cabal update: that should do the trick and create the file. Run cabal user-config init again. Open the mentioned config file and paste inside of it

extra-prog-path: C:\Program Files\Haskell Platform\8.0.1\msys\usr\bin
extra-lib-dirs: C:\Program Files\Haskell Platform\8.0.1\mingw\lib
extra-include-dirs: C:\Program Files\Haskell Platform\8.0.1\mingw\include

now reboot the cmd and run cabal install tidal again - now everything should work. This is how ... (more)

edit retag flag offensive close merge delete

Comments

I think that actually you don't need to install cygwin here - the mingw that comes with the haskell platform should be enough.. In which case you just need to remember to configure the path to that.

yaxu gravatar imageyaxu ( 2016-08-15 01:48:28 -0600 )edit