Ask Your Question
0

Having Tidal MIDI configuration problems

asked 2016-10-11 21:07:37 -0600

onewheeltom gravatar image

updated 2016-12-16 03:03:40 -0600

lennart gravatar image

I have a working Tidal Cycles install on Mac OSX 10.11.6. I wanted to add MIDI support

So first I install midi support:

cabal update
cabal install tidal-midi

I run this in ghci to find my device:

import Sound.Tidal.MIDI.Context
displayOutputDevices >>= putStrLn

and get this output

id: name 
0: SimpleSynth virtual input

so then I do:

devices <- midiDevices

m1 <- midiStream devices "SimpleSynth virtual input" 0 synthController

then I run this with a Shift+Enter:

m1 $ midinote "40 52"

and then I get this error message (which would be much easier if I could cut/paste this from the screen in Atom):

:82:6: error: Couldn't match type `Pattern ParamMap" with Tidal-0.8:Sound.Tidal.Pattern.Pattern
tidal-0.8:Sound.Tidal.Stream.ParamMap'
Nb : `tidal-0.8:Sound.Tidal.Pattern.Pattern' is defined in `Sound.Tidal.Pattern' in package `tidal-0.8.2'
Expected tye : tidal-0.8:Sound.Tidal.Stream.ParamPattern Actual type : ParamPattern

The error continues by deconstructing the command

midinote "40 52" 

In the second argument of `($)', namely 'midinote "40 52"' In the expression: m1 $ midinote "40 52" In an equation for 'it" : it = m1 $ midinote "40 52"

I looked at the instruction on the GitHub page, and it wants me to do this:

Install PortMIDI:

brew install portmidi

I don't have brew installed, so this fails, so I stop here. The initial error looks like it is getting a fully qualified path to ParamPattern, but wants to see just ParamPattern. Any guidance on fixing this would be appreciated.

Thanks, Tom

edit retag flag offensive close merge delete

Comments

Has any one got an answer please as I'm getting the same ?

Mattp gravatar imageMattp ( 2016-10-17 11:10:27 -0600 )edit

2 answers

Sort by ยป oldest newest most voted
1

answered 2016-10-17 15:47:30 -0600

this post is marked as community wiki

This post is a wiki. Anyone with karma >1 is welcome to improve it.

I guess I have solved this. tidal-midi requires tidal-0.8 but the latest version (which was installed by default when you ran cabal install tidal command) is tidal-0.8.2. You can see both of them referred in the error message. The solution is:

ghc-pkg unregister --force tidal-0.8.2
cabal install tidal-midi

second command will install tidal-0.8 as a dependency of tidal-midi.

edit flag offensive delete link more

Comments

That worked perfectly for me. The only thing I found I had to do different was : cabal install tidal-midi --reinstall Thank you

Mattp gravatar imageMattp ( 2016-10-23 08:32:15 -0600 )edit
0

answered 2016-10-17 14:01:09 -0600

bgold gravatar image

How are you importing the TidalMIDI library? I think you want something like import Sound.Tidal.MIDI.Context rather than :m +Sound.Tidal.MIDI.Context.

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2016-10-11 21:07:37 -0600

Seen: 1,957 times

Last updated: Dec 16 '16