Ask Your Question

No sound in Ubuntu

asked 2017-02-07 15:20:49 -0500

Sanju gravatar image

Hi everybody,

I have spent all afternoon trying to make Tidal work on Ubuntu, and I think I'm close to my goal, but there is a (hopefully) last thing to do. OK, I installed everything needed (with supercollider v.3.9). I open supercollider IDE and run "SuperDirt.start". It seemed to go well if it had't been for a "could not initialize audio." message. This is the full log:

*** Welcome to SuperCollider 3.9dev. *** For help press Ctrl-D.
Couldn't set realtime scheduling priority 1: Operación no permitida
SCDoc: Indexing help-files...
SCDoc: Indexed 1345 documents in 0.67 seconds
-> SuperDirt
booting server 'localhost' on address:
jackd 0.124.1
Copyright 2001-2009 Paul Davis, Stephane Letz, Jack O'Quinn, Torben Hohn and others.
This is free software, and you are welcome to redistribute it
under certain conditions; see the file COPYING for details

could not initialize audio.

When I run "d1 $ sound "bd sn"" on Atom it shows "Prelude Sound.Tidal.Context| tidal" what, as I've seen in livecoding videos, seems to be right. But I'm getting no sound.

Anybody knows why is this happening?


edit retag flag offensive close merge delete

2 answers

Sort by » oldest newest most voted

answered 2017-02-07 18:36:43 -0500

lvm gravatar image

Do you have jackd installed and running?

edit flag offensive delete link more

answered 2017-02-08 12:27:58 -0500

Sanju gravatar image

Right! It was a jackd thing. After some configuration I found elsewhere that I had to run it this way: jackd -R -d alsa -d hw:1,0 using the format -d hw:CARD,DEVICE. Man, that was a tricky setup, but everything is ready now.

Thanks for addressing me to the solution.

edit flag offensive delete link more


you're welcome.
there are many (at least 3) front-ends for jackd that could be useful.

lvm gravatar imagelvm ( 2017-02-09 17:15:01 -0500 )edit

Question Tools


Asked: 2017-02-07 15:20:49 -0500

Seen: 788 times

Last updated: Feb 08 '17