Ask Your Question
0

Disable SuperDirt Compressor / Limiter

asked 2017-03-24 19:51:36 -0500

2A03 gravatar image

Hi guys,

Recently I have been using some custom samples which are quite a bit louder than the default Tidal samples. I have noticed that some heavy compression / limiting is kicking in with the extra volume.

I was wondering if it is possible to disable this effect in SuperDirt?

With the previous Dirt sampler I remember there was a startup command to disable the compressor. But I haven't been able to find any info about this with the new SuperDirt implementation.

Here are details of my current setup:

  • SuperCollider (3.8)
  • SuperDirt (3.9)
  • Tidal (0.9)

Many thanks for your help!

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2017-03-24 20:51:43 -0500

bgold gravatar image

It's not a startup option, but if you look for "dirt_monitor" in the core-synths.scd file, that's where the mixing of signals is done before output. There's a line

signal = Limiter.ar(signal);

and that's it. You can remove it or replace with whatever you like.

edit flag offensive delete link more

Comments

Brilliant, that solved it! Thank you very much for your help :-)

2A03 gravatar image2A03 ( 2017-03-24 21:36:21 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2017-03-24 19:51:36 -0500

Seen: 28 times

Last updated: Mar 24