Ask Your Question
0

I want to use my custom samples in my custom path

asked 2017-05-14 13:08:18 -0500

Sunbie gravatar image

Hi all.

I want to use my custom samples. I searched here and got some clues which are :

#1. SuperDirt.start(path:"/My/Path/*")

#2. ~dirt.loadSoundFiles("/My/Path/*")

1 Does not working even I can't use default samples such as 'bd' or 'sn' But I saw this message from the supercolider Post window :

loading 50 sample banks:

... file reading complete

  1. does not working neither but also I got the same message from Post window. In this case, I could use default samples just could not use my custom samples.

Lastly, I have put my custom samples into '{MyPath}/Library/Application\ Support/SuperCollider/downloaded-quarks/Dirt-Samples' It's working everything properly. However I want to split the path of my custom samples in order to do maintenance easier.

What am I doing wrong?

Thanks.

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2017-06-01 01:00:11 -0500

nowavedust gravatar image

updated 2017-06-01 01:03:03 -0500

Tried with the wildcard and similarly it is not working for me either. I removed the wildcard like so:

~dirt.loadSoundFiles("/.../My/Path/diphone/")

I can now access all diphone samples. Currently the site shows to use a wildcard so perhaps it is an issue to be raised.

edit flag offensive delete link more

Comments

~dirt.loadSoundFiles("/.../My/Path/diphone/")

It works only the path is 'Library/Application\ Support/SuperCollider/downloaded-quarks/Dirt-Samples/...' If I set the path as '/Volumes/Data/Users/{USER}/Downloads/...', it dose not work.

Sunbie gravatar imageSunbie ( 2017-06-05 03:33:17 -0500 )edit

Question Tools

1 follower

Stats

Asked: 2017-05-14 13:08:18 -0500

Seen: 111 times

Last updated: Jun 01